东莞热线为您提供全面及时的东莞资讯,内容覆盖东莞新闻事件、体坛赛事、娱乐时尚、产业资讯、实用信息等,设有新闻、体育、娱乐、财经、科技、房产、汽车等30多个内容频道,让您全面了解东莞。

通达信带F10资料的主图指标公式介绍

2018-01-10 13:04:24 来源: 东莞热线 标签: 指数 同比 每股

  M1:=5;M2:=10;M3:=20;M4:=30;M5:=60;M6:=120;M7:=250;M8:=500;N:=9;DRAWGBK(C》0,RGB(00,0,150),RGB(0,00,0),0,‘’,0);利润同比:=STRCAT(STRCAT(‘利润同比:’,CON2STR(FINANCE(43),2)),‘%’);收入同比:=STRCAT(STRCAT(‘收入同比:’,CON2STR(FINANCE(44),2)),‘%’);主营利润率:=STRCAT(STRCAT(‘主营利润率:’,CON2STR(FINANCE(23)/FINANCE(20)*100,2)),‘%’);所属地域:=STRCAT(‘所属地域:’,DYBLOCK);所属行业:=STRCAT(‘所属行业:’,HYBLOCK);所属概念:=STRCAT(‘所属概念:’,GNBLOCK);所属风格:=STRCAT(‘所属风格:’,FGBLOCK);主营业务:=STRCAT(‘主营业务:’,EXTERNSTR(0,1));季报披露:=STRCAT(STRCAT(‘季报披露:’,CON2STR(FINANCE(37),0)),‘季度’);市值:=STRCAT(STRCAT(‘流通市值:’,CON2STR((CAPITAL/1000000)*C,2)),‘亿元’);DRAWTEXT_FIX(1,0.00,0.01,0,利润同比),COLORMAGENTA;DRAWTEXT_FIX(1,0.11,0.01,0,收入同比),COLORMAGENTA;DRAWTEXT_FIX(1,0.22,0.01,0,主营利润率),COLORMAGENTA;DRAWTEXT_FIX(1,0.00,0.07,0,所属地域),COLOR0080FF;DRAWTEXT_FIX(1,0.22,0.07,0,市值),COLOR0080FF;DRAWTEXT_FIX(1,0.00,0.14,0,所属行业),COLORYELLOW;DRAWTEXT_FIX(1,0.00,0.42,0,所属概念),COLORYELLOW;DRAWTEXT_FIX(1,0.00,0.35,0,所属风格),COLORCYAN;DRAWTEXT_FIX(1,0.00,0.28,0,季报披露),COLORYELLOW;DRAWTEXT_FIX(1,0.11,0.07,0,‘流通A股:’)COLOR0080FF;DRAWTEXT_FIX(1,0.15,0.07,0,STRCAT(CON2STR(CAPITAL/1000000,2),‘亿股’))COLOR0080FF;DRAWTEXT_FIX(1,0.11,0.28,0,‘每股收益:’)COLORYELLOW;DRAWTEXT_FIX(1,0.15,0.28,0,STRCAT(CON2STR(FINANCE(30)/FINANCE(1),2),‘元’))COLORYELLOW;DRAWTEXT_FIX(1,0.11,0.14,0,‘每股净资产:元’)COLORYELLOW;DRAWTEXT_FIX(1,0.17,0.14,0,CON2STR(FINANCE(34),2))COLORYELLOW;DRAWTEXT_FIX(1,0.22,0.14,0,‘每股公积金:元’)COLORYELLOW;DRAWTEXT_FIX(1,0.28,0.14,0,CON2STR(FINANCE(18),2))COLORYELLOW;DRAWTEXT_FIX(1,0.11,0.21,0,‘每股未分配:元’)COLORRED;DRAWTEXT_FIX(1,0.17,0.21,0,CON2STR(FINANCE(32),2))COLORRED;DRAWTEXT_FIX(1,0.22,0.21,0,‘经营现金流:元’)COLORRED;DRAWTEXT_FIX(1,0.28,0.21,0,CON2STR(FINANCE(25)/FINANCE(1),2))COLORRED;上市年数:=STRCAT(STRCAT(‘上市年数:’,CON2STR(FINANCE(42)/365,2)),‘年’);DRAWTEXT_FIX(1,0.00,0.21,0,上市年数),COLORCYAN;AAA1:=STRCAT(‘沪深总上涨家数:’,CON2STR(DYNAINFO(60),0));AAA2:=STRCAT(‘沪深总下跌家数:’,CON2STR(DYNAINFO(61),0));DRAWTEXT_FIX(1,0.35,0.28,0,AAA1),COLORRED;DRAWTEXT_FIX(1,0.47,0.28,0,AAA2),COLORGREEN;AAA3:=STRCAT(‘前日收盘:’,CON2STR(DYNAINFO(3),2));AAA4:=STRCAT(‘现价:’,CON2STR(DYNAINFO(7),2));DRAWTEXT_FIX(1,0.35,0.01,0,AAA3),COLORYELLOW;DRAWTEXT_FIX(1,0.47,0.01,0,AAA4),COLORYELLOW;AAA5:=STRCAT(‘成交金额:’,CON2STR(DYNAINFO(10)/100000000,2));AAA6:=STRCAT(‘成交金额:’,CON2STR(DYNAINFO(7)/100000000,2)),‘亿元’;DRAWTEXT_FIX(1,0.35,0.07,0,AAA5),COLORYELLOW;DRAWTEXT_FIX(1,0.42,0.07,0,AAA6),COLORYELLOW;AAA7:=STRCAT(‘换手率:’,CON2STR(DYNAINFO(37)*100,2));AAA8:=STRCAT(‘成交金额:’,CON2STR(DYNAINFO(7)/100000000,2)),‘(%)’;DRAWTEXT_FIX(1,0.47,0.07,0,AAA7),COLORYELLOW;DRAWTEXT_FIX(1,0.52,0.07,0,AAA8),COLORYELLOW;MA5:MA(CLOSE,M1),COLORWHITE;MA10:MA(CLOSE,M2),COLORYELLOW;MA20:MA(CLOSE,M3),COLORMAGENTA;MA30:MA(CLOSE,M4),COLORGREEN;MA60:MA(CLOSE,M5),COLORLIGRAY;MA120:MA(CLOSE,M6),COLORCYAN;MA250:MA(CLOSE,M7),COLOR0080FF;MA500:MA(CLOSE,M8),COLOR808000;NA:=BARSLAST(YEAR!=REF(YEAR,1));NQT:=BACKSET(NA=0,2);NT:=BARSLAST(CROSS(NQT=1,0.5));NC:=REF(REF(C,NT),1);年涨幅:(C-NC)/NC*100NODRAW;DRAWTEXT_FIX(1,0.00,0.49,0,‘[主题投资]:’)COLORMAGENTA;DRAWTEXT_FIX(1,0.04,0.49,0,EXTERNSTR(0,1))COLORMAGENTA;DRAWTEXT_FIX(1,0.00,0.56,0,‘[主营业务]:’)COLORCYAN;DRAWTEXT_FIX(1,0.04,0.56,0,EXTERNSTR(0,2))COLORCYAN;{N:=9;}BC:=(H*0.382 L*0.618 O*0.382 C*0.618)/2;LJ:=IF(INDEXC=C,BC,(BC AMOUNT/(V*100))/2);HT:=REF((HHV(LJ,N*0.691) HHV(LJ,N) HHV(LJ,N*1.309))/3,1);LT:=REF((LLV(LJ,N*0.691) LLV(LJ,N) LLV(LJ,N*1.309))/3,1);ZT:=(HT LT)/2,LINETHICK,COLORYELLOW;STICKLINE(ISLASTBAR=1ANDLJ《ZT,HT,LT,N*8,0),COLORBLUE;STICKLINE(ISLASTBAR=1ANDLJ=ZT,HT,LT,N*8,0),COLORGRAY;STICKLINE(ISLASTBAR=1ANDLJ》ZT,HT,LT,N*8,1),COLOR6600FF;STICKLINE(ISLASTBAR=1,ZT,ZT,N*8,0),COLORYELLOW;箱顶:HT,LINETHICK,COLORRED;箱底:LT,LINETHICK,COLORGREEN;箱中:ZT,LINETHICK,COLORYELLOW;{跌K线蓝色DRAWKLINE(HIGH,OPEN,LOW,CLOSE);STICKLINE(O》=C,C,O,2.6,0),COLORFF0000;STICKLINE(O》=C,C,O,1.9,0),COLORFF3300;STICKLINE(O》=C,C,O,1.2,0),COLORFF6600;STICKLINE(O》=C,C,O,0.5,0),COLORFF9900;{涨K线STICKLINE(C》O,C,O,2.6,0),COLOR000088;

互联网推荐阅读